WordPress 宣布将自动阻止谷歌 FLoC

将自 WordPress 5.8 添加相关代码阻止 FLoC。

WordPress宣布将自动阻止谷歌FLoC

软餐(ruancan.com)获悉,WordPress 今天宣布,计划将谷歌的 FLoC 跟踪技术视为安全问题,并计划默认在 WordPress 网站上将其阻止。

自谷歌开始在全球广泛测试 FLoC 以来,FLoC 遭到了众多组织和机构的批评和抵制。它们之间似乎达成了某种共识——谷歌的 FLoC 计划只是将一种隐私风险替换为另一种隐私风险。

电子前沿基金会(EFF)如此公开批评 FLoC:“FLoC 技术将避免第三方 Cookie 的隐私风险,但它会在这个过程中产生新的风险。它还可能加剧行为广告中许多严重的非隐私问题,包括歧视和掠夺性。”

WordPress 5.8开始阻止 FLoC

WordPress 在今天的公告中指出,WordPress 将 FLoC 技术视为安全问题,并将在以后的版本中开始阻止它。

WordPress 将自 WordPress 5.8 添加相关代码阻止 FLoC,WordPress 5.8 计划于 2021 年 7 月发布。

WordPress 表示:“WordPress 覆盖大约 41% 的网络——这个社区可以通过四行代码帮助对抗种族主义、性别歧视、反 LGBTQ+歧视和对精神病患者的歧视,”

WordPress 计划使用以下四行代码来禁用 FLoC,这将导致该博客平台(及 WordPress 站点)发出 HTTP request header(请求头),告知浏览器应针对该站点禁用 FLoC。

function disable_floc($headers) {
    $headers['Permissions-Policy'] = 'interest-cohort=()';
    return $headers;
  }
 
add_filter('wp_headers', 'disable_floc');

WordPress 解释称,某些站点管理员可能希望启用 FLoC,但这些管理员一般都掌握覆盖上述代码的技术。WordPress 还指出,他们可能会添加一个开关,由管理员控制是否允许 FLoC 的设置。

WordPress 担心的是,那些不了解这一新跟踪技术的用户会在不了解风险的情况下选择开启它。因此,自动禁用 FLoC 符合用户的最大利益。

此外,由于 FLoC 有望更早推出,WordPress 正在考虑将该代码移植到 WordPress 的早期版本。


对于一般的互联网用户,可通过安装浏览器扩展来阻止 FLoC 的跟踪,读者可阅读软餐(ruancan.com)的这篇报道

原创文章,转载需获得本站授权。欢迎加入软餐读者群:软餐食堂   软餐食堂

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注